やっぱり間違えてた(´・ω・`)

 なんかバージョンを変えたら解決しました。
 最初に試してた奴のバージョンは 1.99_06、今回のが 0.88。
 どうも新しいのは Perl 5.8.* で追加された Encode モジュールのラッパみたいで、一応 Jcode 0.88 相当のコードは含まれてる物の内部構造が大幅に変わってる模様。古いコードを Jcode::_Classic に押し込めたおかげでおかしな事になった様です。
 つーことで、同じような罠に引っかかってここにきた人、Jcode 0.* に差し替えましょう(´・ω・`)

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

CAPTCHA